monitoring: added services

This commit is contained in:
eyjhb 2025-03-14 16:45:42 +01:00
parent efb17ea7fa
commit cb121c5369
Signed by: eyjhb
GPG key ID: 609F508E3239F920
12 changed files with 228 additions and 0 deletions

View file

@ -37,6 +37,22 @@ in {
const Dialect = require("knex/lib/dialects/sqlite3/index.js");
'')
# TODO(eyJhb): do we really want this?
(pkgs.writeText "uptime-kuma-disable-metrics-auth.patch" ''
diff --git a/server/server.js b/server/server.js
index db58ae82..d650a42a 100644
--- a/server/server.js
+++ b/server/server.js
@@ -292,7 +292,7 @@ let needSetup = false;
// Prometheus API metrics /metrics
// With Basic Auth using the first user's username/password
- app.get("/metrics", apiAuth, prometheusAPIMetrics());
+ app.use("/metrics", prometheusAPIMetrics());
app.use("/", expressStaticGzip("dist", {
enableBrotli: true,
'')
];
});
};