updated sources + patches + more patches
This commit is contained in:
parent
ce4d807d53
commit
7313bb8344
8 changed files with 60 additions and 38 deletions
|
@ -5,13 +5,13 @@ let
|
|||
|
||||
resetPasswordStartPatch = pkgs.writeText "lldap-reset-password-start.patch" ''
|
||||
diff --git a/server/src/main.rs b/server/src/main.rs
|
||||
index 71e4928..63be13c 100644
|
||||
index 6f42473..b3746a1 100644
|
||||
--- a/server/src/main.rs
|
||||
+++ b/server/src/main.rs
|
||||
@@ -158,7 +158,7 @@ async fn set_up_server(config: Configuration) -> Result<ServerBuilder> {
|
||||
@@ -171,7 +171,7 @@ async fn set_up_server(config: Configuration) -> Result<ServerBuilder> {
|
||||
))?;
|
||||
}
|
||||
if config.force_update_private_key || config.force_ldap_user_pass_reset {
|
||||
if config.force_update_private_key || config.force_ldap_user_pass_reset.is_yes() {
|
||||
- bail!("Restart the server without --force-update-private-key or --force-ldap-user-pass-reset to continue.");
|
||||
+ // bail!("Restart the server without --force-update-private-key or --force-ldap-user-pass-reset to continue.");
|
||||
}
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue